Write-up published
Read our write-up of this incident at https://icw.li/W4NKcdRvR
Resolved
The incident has been resolved, and the service has returned to normal.
All mail services have fully recovered. Message delivery, directory indexing, and filtering are operating normally.
The incident was traced to malformed data being returned by the third-party SpamHaus Anti-Spam/Reputational Data service, which triggered false positives within IceWarp’s intrusion prevention system and led to widespread blacklisting of legitimate mail exchangers.
Actions Taken:
Cleared all incorrect blacklists and rebuilt the directory cache
Verified stable and consistent message flow across all transport layers
Temporarily eliminated the use of the third-party SpamHaus data from all transport layers until it can either be safely reintroduced or replaced with an alternative solution
Next Steps:
Continue monitoring inbound/outbound delivery metrics for stability
Evaluate long-term replacement or reintegration strategy for reputational data services
Monitoring
A fix has been implemented, and we are monitoring service metrics to verify resolution.
Working with IW support staff, we have identified the root cause to be SpamHaus's service being down, resulting in all mail being rejected, as well as a simultaneous corruption of the directory cache database. We have implemented a fix and are observing service recovery. Items may not be visible in WebMail until the directory cache is rebuilt and reindexed. Continuing to monitor to ensure issue is resolved.
Investigating
We have confirmed an issue exists with IceWarp Mail Exchange Services the service and are working to determine a root cause.